Author Topic: Autoupdater.exe issues  (Read 95 times)

0 Members and 1 Guest are viewing this topic.

Offline Light Elf

  • Hero Member
  • *****
  • Posts: 709
  • Karma: 0
    • View Profile

  • Total Badges: 30
    Badges: (View All)
    Search 10 Poll Votes Poll Voter
Autoupdater.exe issues
« on: July 13, 2017, 12:27:13 pm »
I am currently experiencing issues with the autoupdater.exe program and I know of atleast 1 other person having the exact same problems preventing the game from working for us.

Tried to run the game 2 days ago and it just didnt work because the file autoupdater.exe nolonger existed. - So I tried a complete Re-Install

After the Install I ran the autoupdater.exe, It launched fine so I connected to the Test world and it appeared to download all the files correctly but when it goes to launch the client Immedialty I get an error about the Itemdef.dat and it launches the V1 client after that followed with the "Your client version is out of date" error and I am forced to close the game.

After the game closes when I attempt to re-run the autoupdater.exe it is missing again and I am forced to start over with another Re-Install,

So Basically I repeated the same steps as above over again but this time trying the Upira server instead and I got slightly different results, Everythign was the same up until right after the Itemdef.dat error and I need to try and restart the game, This time the Autoupdater.exe file is still there but I get the error message "Windows cannot access the specified device, path, or file, You may not have the appropriate permissions to access the item."

I have tried running as administrator, did not work and I recieve the exact same error message
I have tried making it not read only, did not work same error message
Tried making it not read only and running as administrator, Same error message

I have tried all of the above steps multiple times through 6 different installs and come up with the exact same result every time,
I know of atleast 1 other person having this exact same problem, but another who does not seem to have any issues at all..
Is abybody else having this problem or does anybody know of a solution, Any ideas will be appreciated lol I have done all i can think of

Offline Mickey Kudlo

  • Administrator
  • *****
  • Posts: 1378
  • Karma: 24
    • MSN Messenger - mkudlo@hotmail.com
    • View Profile
    • http://www.rpgwo.com
    • Email

  • Total Badges: 38
    Badges: (View All)
    10 Poll Votes 10 Polls Nineth year Anniversary
Re: Autoupdater.exe issues
« Reply #1 on: July 13, 2017, 01:05:26 pm »
You downloaded and ran the latest http://rpgwo.com/download/RPGWOsetup.zip ? Maybe change the install path to an easier read/writable path, like somewhere in your User folder.
Try running the updater in Compatibility Mode?
If the .exe is disappearing then could be Virus Scanner removing it.
You may have conquered my worlds, but I destroyed them!

Offline Light Elf

  • Hero Member
  • *****
  • Posts: 709
  • Karma: 0
    • View Profile

  • Total Badges: 30
    Badges: (View All)
    Search 10 Poll Votes Poll Voter
Re: Autoupdater.exe issues
« Reply #2 on: July 13, 2017, 01:30:41 pm »
I tried installing to my dopigents folder in my user account instead of the default programfiles(x86) and I was able to get past the previous itemdef.dat error and the V3 client launched and I was able to get to the log in screen, but when I closed the program and went to re run the autoupdater.exe I get the error message "Windows cannot access the specified device, path, or file, You may not have the appropriate permissions to access the item."

Same error as before

also half of my previous attempts were with the most recent installer from your website and after those didnt work I tried an old client installer from the early 2000's aswell all of which had the same results, I dont have any antivirus software yet and this is a brand new computer about a month old, the game worked fine less then 2 weeks ago, I havnt done really anything with the computer that would cause these problems that I am aware of

Offline Light Elf

  • Hero Member
  • *****
  • Posts: 709
  • Karma: 0
    • View Profile

  • Total Badges: 30
    Badges: (View All)
    Search 10 Poll Votes Poll Voter
Re: Autoupdater.exe issues
« Reply #3 on: July 13, 2017, 01:42:09 pm »
I Troubleshooted compatability aswell and it says "The specified path does not contain a valid program, Please select a valid program (ending with .exe or .msi)." the file location its refering to is clearly marked   "C:\Users\**Censored**\Dopigents\RPG World Online\AutoUpdater.exe"

It appears to me every time I install and connect to a server the autoupdater overwrites itself with a corrupted version of iteself during the update process at the start of the server connection preventing me from ever launching it a second time without deleting and reinstalling

Offline Light Elf

  • Hero Member
  • *****
  • Posts: 709
  • Karma: 0
    • View Profile

  • Total Badges: 30
    Badges: (View All)
    Search 10 Poll Votes Poll Voter
Re: Autoupdater.exe issues
« Reply #4 on: July 13, 2017, 01:43:30 pm »
Apparantly someone is a funnyguy and has it set to change D o c u m e n t s into dopigents

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
817 Views
Last post April 19, 2007, 10:37:27 pm
by Komodo
10 Replies
1235 Views
Last post November 20, 2007, 02:46:59 am
by Komodo
2 Replies
2072 Views
Last post September 13, 2008, 08:31:20 pm
by Morgram
47 Replies
5349 Views
Last post February 02, 2010, 05:54:00 pm
by xadves
3 Replies
101 Views
Last post July 28, 2017, 10:55:00 am
by Gimpy